Project

General

Profile

Wiki » History » Version 5

Mark ter Linden, 06/28/2017 11:51 AM

1 5 Mark ter Linden
[[PyCAMA tool]]
2 5 Mark ter Linden
3 5 Mark ter Linden
[[L2 Quality Control]]
4 5 Mark ter Linden
5 1 Maarten Sneep
h1. Required Python packages
6 1 Maarten Sneep
7 1 Maarten Sneep
The following external packages are required (which may in turn require further packages):
8 1 Maarten Sneep
9 1 Maarten Sneep
* @matplotlib@ http://matplotlib.org/
10 1 Maarten Sneep
* @mpl_toolkits.basemap@ http://matplotlib.org/basemap/
11 1 Maarten Sneep
* @numexpr@ https://github.com/pydata/numexpr
12 1 Maarten Sneep
* @numpy@ http://www.numpy.org/
13 1 Maarten Sneep
* @netCDF4@ http://unidata.github.io/netcdf4-python/
14 2 Maarten Sneep
* @h5py@ http://www.h5py.org/
15 2 Maarten Sneep
* @lxml@ http://lxml.de/ 
16 3 Maarten Sneep
* @isodate@ https://pypi.python.org/pypi/isodate
17 4 Maarten Sneep
18 4 Maarten Sneep
h1. Python version
19 4 Maarten Sneep
20 4 Maarten Sneep
Python 3 is required, current testing has been performed on python 3.4 and 3.5. 
21 4 Maarten Sneep
22 4 Maarten Sneep
h1. OS support
23 4 Maarten Sneep
24 4 Maarten Sneep
Testing has been done under Linux (Fedora 23 and 24). The code is expected to work with other linux and unix-like systems (including macOS), provided the packages mentioned above are available. Using "Continuum Anaconda":https://www.continuum.io/downloads is probably the easiest way to get started, especially matplotlib is notorious to install yourself.
25 4 Maarten Sneep
26 4 Maarten Sneep
No testing has been done on Windows. There are a few areas where compatibility issues may arise. Let me know if you find issues.