Project

General

Profile

Support #574

Optimization of ebischeme can be problematic

Added by Philippe Le Sager over 3 years ago. Updated almost 2 years ago.

Status:
In Progress
Priority:
Normal
Category:
-
Target version:
-
Start date:
06/13/2016
Due date:
% Done:

100%


Description

Not sure how much of an issue it is, but an optimization problem came up with the new Cray-Braodwell environment at ECMWF with the intel environemnt. It happens only with cb05+M7+with_budget. With the default ifort environment (ifort 15), it is not possible to compile ebischeme. I got a "catastrophic" error message. The only way to compile that routine in that configuration, was to replace:

-fp-model strict
with
-fp-model strict -fp-model source
or
-fp-model source
Note that it does not compile either with
-fp-model precise
Not sure what are the consequences of that change. According to manual, -fp-model source option "causes intermediate results to be rounded to the precision defined in the source code".

History

#1 Updated by Philippe Le Sager over 3 years ago

Somehow the issue is also happening with cbm4, when using some of the without flags. The same change in the optimization flags fixes it.

#2 Updated by Philippe Le Sager almost 2 years ago

  • Status changed from New to Closed
  • % Done changed from 20 to 100

A new trial, and success: ebischeme.F90 is compiled without the -fp-model source flag.
This has more to do with code changes than compiling environment:

[5072] >>> ftn -V
Intel(R) Fortran Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 15.0.1.133 Build 20141023
Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.

#3 Updated by Philippe Le Sager almost 2 years ago

  • Status changed from Closed to In Progress

Reopened. This is still the case as far as I know.

Also available in: Atom PDF