Project

General

Profile

Bug #549

Restarbility broken

Added by Philippe Le Sager over 3 years ago. Updated over 2 years ago.

Status:
In Progress
Priority:
High
Category:
-
Target version:
-
Start date:
05/17/2016
Due date:
% Done:

50%


Description

It was reported that the full-chemistry TM5-MP is not restartable anymore: stopping and restarting from a restart file changes results compared to a run done in one shot. First tests show that it happens with and without M7, so nothing to do with M7. Runs with only advection, convection, diffusion and wet/dry deposition are fine. So the problem is with sedimentation, boundary, chemistry or emissions.

History

#1 Updated by Philippe Le Sager about 3 years ago

  • % Done changed from 30 to 40

Same problem with cbm4. So far I can tell that it is a problem with the emissions, probably NOx.

#2 Updated by Philippe Le Sager about 3 years ago

The problem is happening with the 3D NOx emissions. If the emissions are not vertically distributed, but added in the first layer, the problem goes away.

#3 Updated by Philippe Le Sager about 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

Solved. The call to ss_monthly_update (sources and sinks update) had to be moved after meteo setup for a consistent vertical remapping of the NOx emissions across the two types of runs (with and without monthly restart). The call to ss_monthly_update must also be before the call to Proces_Update, because of the getDMS call down the line. This has been done, tested, and committed in r347.

#4 Updated by Philippe Le Sager about 3 years ago

  • Status changed from Resolved to Closed

#5 Updated by Philippe Le Sager about 3 years ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 50

Reopened. It was not thoroughly tested, and it turns out that there is a problem with M7 sedimentation and/or chemistry.

#6 Updated by Philippe Le Sager over 2 years ago

I've isolated the problematic lines of code. If I comment the calls to sedimentation_calcv and to deposition_calcv, TM5 is restartable. These calls are found in:

sedimentation.F90/sedimentation_apply
which is called from
sources_sinks.F90/sources_sinks_apply

Also available in: Atom PDF