Project

General

Profile

Bug #27221

[PyCAMA] crash when encountering empty files

Added by Maarten Sneep about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
07/22/2020
Due date:
07/22/2020
% Done:

100%


Description

Files without valid retrievals will cause a crash of PyCAMA 0.10.1. The cause has been identified, and a patch has been prepared and released. No new configuration file is required.

PyCAMA-0.10.1.zip (3.66 MB) Maarten Sneep, 07/22/2020 02:49 PM

History

#1 Updated by PDGS Operations about 1 year ago

For completeness, the following PyCAMA data has not been generated:
- For the PyCAMA run on 2020-07-15: AAI, ALH
- For the PyCAMA run on 2020-07-17: ALH, NO2
- For the PyCAMA run on 2020-07-18: FRESCO, HCHO
- For the PyCAMA run on 2020-07-19: HCHO, CO

The reasons as to why those were not generated are twofold. Initially those requests failed do to the not working PyCAMA version 0.10.0/0.10.1. After the patch delivery of PyCAMA 0.10.2 the requests were resumed. Partially the input data was already removed from the pickup-point and the processing could not be started. For the remaining requests with input data still available we went several times in the well-known error as outlined in Redmine #25081. Those issues are still subject to investigation on PDGS side.

Also available in: Atom PDF