Project

General

Profile

Feature #14761

[Pycama] Use explicit fill colour for missing values in L3 plots

Added by Mattia Pedergnana 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/13/2018
Due date:
% Done:

100%


Description

The values of the CF=0 are plotted white instead of blue. In the plot below, for example the area in the North of Africa is shown with white color instead of Dark Blue. DLR checked the original L2 NetCDF4 files and they are fine.

Pycama output

Real Data

The plotting routine seems also to show artifacts in the FRESCO product for those pixels where CF=0

world_cloud_fraction_20180912T000638-20180913T022723.png View (3.5 MB) Maarten Sneep, 01/16/2019 04:33 PM

History

#1 Updated by Mattia Pedergnana 3 months ago

  • Description updated (diff)

#2 Updated by Maarten Sneep 3 months ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Feedback

This is not a bug, this is a feature. If any of the parameters has a fill value for a pixel, this pixel will be removed from all parameters. This is done to ensure that correlation coefficients are correct (these must be taken over the same dataset for all parameters). Since the cloud albedo, cloud pressure are set to fill values for pixels with cloud fraction identical to 0, these are filtered out.

#3 Updated by Maarten Sneep 3 months ago

PS. May I bring issues #14161 and #9321 to your attention. These are meant to update the PyCAMA configuration and collect information on time-dependent monitoring.

I also noticed that there is no qa_value filter in the configuration for the cloud product, you may want to add this.

#4 Updated by Maarten Sneep 3 months ago

  • Project changed from L2 to PyCAMA

#5 Updated by Ronny Lutz 3 months ago

I think what is a bit confusing here is that due to the white map background a fill value appears "white". Therefore in the plots for the CF both the fill values but also the CF=1 cases appear white.
An unexperienced user may have the difficulty to distinguish if a pixel is white because it has CF=1 or if it is white because the pixel has CF=0 and is consequently filtered out because there was no ROCINN retrieval triggered.

#6 Updated by Maarten Sneep 3 months ago

I'll see what I can do for these missing values.

#7 Updated by Maarten Sneep 3 months ago

  • Subject changed from [Pycama] wrong visualization of the cloud fraction of the CLOUD_ product to [Pycama] Use explicit fill colour for missing values in L3 plots
  • Status changed from Feedback to New
  • Target version set to PyCAMA 0.9.0

Use an explicit fill colour for areas where no data is available (such as cloud-free areas in the example here).

#8 Updated by Maarten Sneep 2 months ago

  • Status changed from New to Resolved

Missing data will now be plotted in a different colour (grey). With the colour tables that are used this should stand out as missing data. (dark grey is used for values higher than the range of the plot, light grey for values lower than the range, and middle grey for bad of missing values). The first two were already in place, and that is what you saw in the FRESCO plot.

#9 Updated by Maarten Sneep 2 months ago

Here is the same day plotted with the updated code.

#10 Updated by Maarten Sneep about 2 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 30 to 100

Also available in: Atom PDF